[yadifa-users] yadifa 2.2.0 crash

Anand Buddhdev anandb at ripe.net
Fri Jul 15 17:11:01 CEST 2016


Hi yadifa developers,

yadifa 2.2.0 is crashing on me. The first time I start it, with no zones
loaded or cached anywhere, it starts up fine. If I stop it, and then
start it again, it starts to load in cached zones from disk, and during
this process, crashes:


...
...
...
2016-07-15 15:04:38.960880 | server   | I | zone load:
0.8.2.2.2.0.a.2.ip6.arpa.: loading AXFR file in '/var/yadifa/xfr/'
2016-07-15 15:04:38.961033 | server   | I | zone load:
'0.8.2.2.2.0.a.2.ip6.arpa.' loaded: SUCCESS ( 0.000601s)
2016-07-15 15:04:38.961562 | server   | I | zone load:
0.8.2.b.0.0.a.2.ip6.arpa.: loading AXFR file in '/var/yadifa/xfr/'
2016-07-15 15:04:38.961653 | server   | I | zone load:
'0.8.2.b.0.0.a.2.ip6.arpa.' loaded: SUCCESS ( 0.000591s)
2016-07-15 15:04:38.974529 | server   | E | /var/log/yadifa//sig-11-27510
2016-07-15 15:04:38.974561 | server   | E | got signal 11 at
time=1468595078 for address 0000000000000000
2016-07-15 15:04:38.974563 | server   | E | rax=0000000000000000
2016-07-15 15:04:38.974565 | server   | E | rcx=00007FDFCCE89320
2016-07-15 15:04:38.974566 | server   | E | rdx=00007FDFEAC5A4E8
2016-07-15 15:04:38.974567 | server   | E | rbx=00007FDFCCE89320
2016-07-15 15:04:38.974569 | server   | E | rsi=000000000000000A
2016-07-15 15:04:38.974570 | server   | E | rdi=0000000000000000
2016-07-15 15:04:38.974571 | server   | E | rsp=00007FDFE4D7DDE0
2016-07-15 15:04:38.974573 | server   | E | rbp=00007FDFE4D7DE00
2016-07-15 15:04:38.974574 | server   | E | r8 =0000000000000004
2016-07-15 15:04:38.974575 | server   | E | r9 =00007FDFCCE89320
2016-07-15 15:04:38.974577 | server   | E | r10=00007FDFE4D7DAF0
2016-07-15 15:04:38.974578 | server   | E | r11=0000000000000202
2016-07-15 15:04:38.974579 | server   | E | r12=00007FDFE9CEE360
2016-07-15 15:04:38.974583 | server   | E | r13=00007FDFE4D829C0
2016-07-15 15:04:38.974585 | server   | E | r14=0000000000000000
2016-07-15 15:04:38.974587 | server   | E | r15=0000000000000003
2016-07-15 15:04:38.974588 | server   | E | rip=00007FDFEAC132E1
2016-07-15 15:04:38.974589 | server   | E | efl=0000000000010202
2016-07-15 15:04:38.974734 | server   | E |     [0]: /usr/sbin/yadifad()
[0x4262f8]
2016-07-15 15:04:38.974741 | server   | E |     [1]:
/lib64/libpthread.so.0(+0xf7e0) [0x7fdfe9ae17e0]
2016-07-15 15:04:38.974743 | server   | E |     [2]:
/usr/lib64/libdnsdb.so.3(+0x1e2e1) [0x7fdfeac132e1]
2016-07-15 15:04:38.974745 | server   | E |     [3]:
/usr/lib64/libdnsdb.so.3(+0x20a1b) [0x7fdfeac15a1b]
2016-07-15 15:04:38.974747 | server   | E |     [4]:
/usr/lib64/libdnsdb.so.3(journal_close+0xc0) [0x7fdfeac16f06]
2016-07-15 15:04:38.974749 | server   | E |     [5]:
/usr/lib64/libdnsdb.so.3(journal_last_soa+0x2e3) [0x7fdfeac173b0]
2016-07-15 15:04:38.974751 | server   | E |     [6]: /usr/sbin/yadifad()
[0x411ea8]
2016-07-15 15:04:38.974752 | server   | E |     [7]: /usr/sbin/yadifad()
[0x412c86]
2016-07-15 15:04:38.974754 | server   | E |     [8]:
/usr/lib64/libdnscore.so.3(+0x5f65b) [0x7fdfea9c065b]
2016-07-15 15:04:38.974756 | server   | E |     [9]:
/lib64/libpthread.so.0(+0x7aa1) [0x7fdfe9ad9aa1]
2016-07-15 15:04:38.974758 | server   | E |     [10]:
/lib64/libc.so.6(clone+0x6d) [0x7fdfe9826aad]
2016-07-15 15:04:38.974761 | server   | E | pid: 27510 thread id: (
2016-07-15 15:04:38.974765 | server   | E | page at 0000000000000000 is
not mapped.
2016-07-15 15:04:38.975809 | server   | E | CRITICAL ERROR


If you tell me what more information you need to pinpoint the crash, I'd
be happy to provide it. However, this doesn't look too good at the moment.

Regards,
Anand


More information about the yadifa-users mailing list